SORU
14 Kasım 2013, PERŞEMBE


API 19 isValidFragment Android

Ben Android KitKat ile benim app çalıştığınızda PreferenceActivity bir hata var.

PreferenceActivity alt isValidFragment(Dizi) Fragmanı sınıfı geçerli olduğunu doğrulamak için geçersiz kılmak gerekir! com.crbin1.labeltodo.ActivityPreference eğer parça com kontrol etmedi.crbin1.labeltodo.StockPreferenceFragment geçerlidir

Belgelerinde aşağıdaki açıklamayı buldum

korumalı boolean isValidFragment (String fragmentName)

API eklendi düzeyi 19

Alt sınıflar bu yöntemi geçersiz kılmak ve belirli bir bölümü, bu aktivite eklenmesi için geçerli bir tür olduğunu doğrulamak gerekir. Varsayılan uygulama android için yapılmış:KİTKAT daha targetSdkVersion üstü için true değerini döndürür. Sonraki sürümler için bir istisna olacak.

Bu sorunu gidermek için herhangi bir örnek bulamıyorum.

CEVAP
22 Kasım 2013, Cuma


Bu deneyin... bu parçanın geçerliliğini kontrol ediyoruz.

protected boolean isValidFragment(String fragmentName) {
  return StockPreferenceFragment.class.getName().equals(fragmentName);
}

Bunu Paylaş:
  • Google+
  • E-Posta
Etiketler:

YORUMLAR

SPONSOR VİDEO

Rastgele Yazarlar

  • ethr95awd

    ethr95awd

    8 Kasım 2006
  • Metheud

    Metheud

    9 EYLÜL 2006
  • MyCyberAcademy

    MyCyberAcade

    2 EKİM 2011