SORU
29 HAZİRAN 2011, ÇARŞAMBA


İOS için uygulamalar 4.0 sınırlama armv6 desteği eklememe gerek var mı ?

Şu anda hem armv6 ve armv7 için hazırlıyorum. Ayrıca 4.0 olarak hedef iOS sürümünü kurdum.

Tüm cihazlar iOS 4.0 çalıştırabilen armv6 için derleme durdurabilirim böylece armv7 ve haklı mıyım?

Büyük bir anlaşma değil, ama benim app ikili eğer yapabilirsem biraz daha küçük olacağı anlamına gelir.

CEVAP
29 HAZİRAN 2011, ÇARŞAMBA


Kusura bakma ama doğru değil mi. İPhone 3G ve iPod Touch 2G iOS 4 çalıştıramaz (zar zor) ve armv6 işlemci vardır.

ARMv8 / ARM64 = iPhone 5s, iPad Air, Retina iPad Mini
ARMv7s = iPhone 5, iPhone 5c, iPad 4
ARMv7  = iPhone 3GS, iPhone 4, iPhone 4S, iPod 3G/4G/5G, iPad, iPad 2, iPad 3, iPad Mini  
ARMv6  = iPhone, iPhone 3G, iPod 1G/2G

iOS 4.3 ARMv7 gerektirir. Dağıtım Hedef ise 4.3, armv6 desteği dışında bırakabilirsiniz.

Böyle büyük mükafat 4.5 gibi olamaz armv6 @Paul de Lange kurmak

Bunu Paylaş:
  • Google+
  • E-Posta
Etiketler:

YORUMLAR

SPONSOR VİDEO

Rastgele Yazarlar

  • Alexander Johnson

    Alexander Jo

    26 Temmuz 2008
  • huyked

    huyked

    28 Mart 2008
  • warningthepeople

    warningthepe

    21 EYLÜL 2011

İLGİLİ SORU / CEVAPLAR