SORU
4 Mart 2013, PAZARTESİ


Kaç yaşında olanlar güncellemeden başka bir bağımlılık yükleyebilir miyim?besteci:

Birkaç bağımlılıkları ile bir projem var ve bir tane daha yüklemek istiyorum, ama diğerleri bu şekilde devam etmek istiyorum. composer.json ama eğer composer install, ben çalıştırmak aşağıdaki çıktıyı alıyorum düzenlenen yaptım:

Installing dependencies from lock file
Warning: The lock file is not up to date with the latest changes in composer.json. You may be getting outdated dependencies. Run update to update them.
Your requirements could not be resolved to an installable set of packages.

Problem 1
    - laravel/framework dev-master requires ext-mcrypt * -> the requested PHP extension mcrypt is missing from your system.
    - laravel/framework dev-master requires ext-mcrypt * -> the requested PHP extension mcrypt is missing from your system.
    - Installation request for laravel/framework dev-master -> satisfiable by laravel/framework dev-master.

Öncelikle, bu konuda şikayet var neden bilmiyorum mcrypt yüklü var.

Nasıl bu yeni bağımlılık yükleyebilir miyim?

Benim besteci.json:

{
    "require": {

        "opauth/opauth": "*",
        "opauth/facebook": "*",
        "opauth/google": "*",
        "opauth/twitter": "*",

        "imagine/Imagine": "dev-develop",

        "laravel/framework": "4.*",
        "loic-sharma/profiler": "dev-master"
    },
    "autoload": {
        "classmap": [
            "app/libraries",
            "app/commands",
            "app/controllers",
            "app/models",
            "app/database/migrations",
            "app/tests/TestCase.php"
        ]
    },
    "minimum-stability": "dev"
}

CEVAP
5 Mart 2013, Salı


Yeni bir paket ve sadece yüklemek için iki seçeneğiniz vardır:

  1. Besteci için el ile ekleyin.json, sonra çalıştırın

    composer update new/package
    

    ya da:

  2. require komutunu kullanın. Sadece çalıştırın

    composer require new/package
    

    besteci en iyi sürümünü kullanmak için kısıtlama tahmin etmek, ya da sürüm kısıtlaması gibi açıkça belirtin

    composer require new/package ~2.5
    

    Her iki şekilde de, Besteci besteci senin için paket eklemek.json, yüklemek, ve besteci ekleyebilirsiniz.kilit.

Laravel ve mcrypt ile soru soru soran bu konularda: düzgün CLİ php etkin olduğunu kontrol edin.ını. Eğer php -m mcrypt sonra listede değilse bile eksik.

Bunu Paylaş:
  • Google+
  • E-Posta
Etiketler:

YORUMLAR

SPONSOR VİDEO

Rastgele Yazarlar

  • amc

    amc

    21 EYLÜL 2005
  • DJAndrewRyan

    DJAndrewRyan

    22 Ocak 2007
  • rtisticsdev

    rtisticsdev

    31 Mayıs 2012