SORU
7 EKİM 2009, ÇARŞAMBA


Virtualenv ile farklı Python sürümü kullanın

Debian bir sistem şu anda python 2.5.4 ile çalıştırıyorum. Virtualenv düzgün yüklü aldım, her şey iyi çalışıyor. Python farklı bir sürümü ile bir virtualenv kullanabileceğim bir ihtimal var mı?

Python 2.6.2 ve bazı virtualenv ile kullanmak istiyorum derlenmiş. İkili dosyanın üzerine yazmak yeterli mi? Ya da kütüphanelere konuda bir şey değiştirmek zorunda mıyım?

CEVAP
7 EKİM 2009, ÇARŞAMBA


Kullandığınız Python çalıştırılabilir belirtmek için virtualenv örneği oluştururken-p bayrağı kullanın, örneğin sadece istediğiniz:

virtualenv -p /usr/bin/python2.6 <path/to/new/virtualenv/>

Bunu Paylaş:
  • Google+
  • E-Posta
Etiketler:

YORUMLAR

SPONSOR VİDEO

Rastgele Yazarlar

  • Andrew_Huang

    Andrew_Huang

    10 ŞUBAT 2006
  • Canceriansoul

    Canceriansou

    15 Ocak 2011
  • MultiPlayStationMan

    MultiPlaySta

    17 Aralık 2009

İLGİLİ SORU / CEVAPLAR