SORU
3 Ocak 2014, Cuma


'pip' ile " başarısız;gerektirir&;= 0.8, en son setuptools gt dağıtım-bilgi"

pip, I (1.5) son sürümünü kullanarak birkaç paket güncellemek için çalışırken bir hata alıyorum. Örneğin, sudo pip install -U pytz ile başarısız olur:

Wheel installs require setuptools >= 0.8 for dist-info support.
pip's wheel support requires setuptools >= 0.8 for dist-info support.

Bu mesaj ne* *11 ya da anlamıyorum.


Bu hata için: günlük özel durum bilgileri

Exception information:
Traceback (most recent call last):
  File "/Library/Python/2.7/site-packages/pip/basecommand.py", line 122, in main
    status = self.run(options, args)
  File "/Library/Python/2.7/site-packages/pip/commands/install.py", line 230, in run
    finder = self._build_package_finder(options, index_urls, session)
  File "/Library/Python/2.7/site-packages/pip/commands/install.py", line 185, in _build_package_finder
    session=session,
  File "/Library/Python/2.7/site-packages/pip/index.py", line 50, in __init__
    self.use_wheel = use_wheel
  File "/Library/Python/2.7/site-packages/pip/index.py", line 89, in use_wheel
    raise InstallationError("pip's wheel support requires setuptools >= 0.8 for dist-info support.")
InstallationError: pip's wheel support requires setuptools >= 0.8 for dist-info support.

CEVAP
3 Ocak 2014, Cuma


Bu benim için çalıştı:

sudo pip install setuptools --no-use-wheel --upgrade

Sudo kullanımı olduğunu unutmayın

GÜNCELLEME

Pencere üzerinde sadece yönetici olarak pip install setuptools --no-use-wheel --upgrade çalıştırmak gerekir. Unıx/linux, sudo komut izinleri yükseltmek için.

GÜNCELLEME

Bu 1.5.1 giderildi görünüyor.

Bunu Paylaş:
  • Google+
  • E-Posta
Etiketler:

YORUMLAR

SPONSOR VİDEO

Rastgele Yazarlar

  • Flash CS6 Video Tutorials for Beginners (Actionscript 3 Gaming)

    Flash CS6 Vi

    14 EYLÜL 2012
  • MultiPlayStationMan

    MultiPlaySta

    17 Aralık 2009
  • Drakinen

    Drakinen

    1 EYLÜL 2008

İLGİLİ SORU / CEVAPLAR