SORU
12 EYLÜL 2010, Pazar


Nasıl 1.9 Ruby güncellemek için.Mac x?

Mac bilgisayarımda yeni bir kullanıcı hesabı oluşturdum ve 1.8.7 snow leopard varsayılan ruby on güncel sürüm (1.9.2) güncellemek için çalışıyorum. Biri beni 1.9.2 için 1.8 benim mac Ruby on güncellemek için en iyi yöntem öğretici açıklamak için bir işaret olabilir mi? Teşekkürler

CEVAP
6 Ocak 2013, Pazar


GibiTeneke Adamgöstermektedir (yukarıda)RVM(Ruby Versiyon Yöneticisi)StandartOS X üzerinde Ruby kurulumu yükseltmek için: https://rvm.io

Başlamak için, bir açıkTerminalPencere ve aşağıdaki komutu çalıştırın:

\curl -L https://get.rvm.io | bash -s stable --ruby

( gerekecektirgüvenRVM komutunu bu Takım Devkötü niyetli değil- eğer bir sensinparanoyak penguenbenim gibi, her zaman kitap okuyunkaynakTam o Zaman.: https://github.com/wayneeseguin/rvm ) ^strong>terminali yeniden başlatmanız gerekiyorrvm komutu çalışmıyor.

rvm list known

( size gösteriren son kullanılabilir sürümYakut )

rvm install ruby-2.0.0-p247

Belirli bir sürümü için izledi

rvm use ruby-2.0.0-p247

yaeğer sadece (geçerli) en son sürümü:

rvm install current && rvm use current

( şu anki kararlı sürümü yükler - ruby-2.0.0-p247 - lütfen yeni versiyonu çıktı bu wiki güncelleştirme yazma anda )

Derleme Ruby ile ilgili notBenim durumda ben de yüklemek zorunda kaldımHomebrewAlmak için http://mxcl.github.com/homebrew/taşlarSırayla yüklemek için zorlar ihtiyacım vardı (**15)Böyle büyük mükafateğer zaten sığınak mi () https://itunes.apple.com/us/app/xcode/id497799835VE/VEYAGCC paketini kurun: https://github.com/kennethreitz/osx-gcc-installer çalıştırma hataları önlemek için "olun".

Düzenleme:GibiMavericksgcc ve paketleri oluşturmak için ihtiyacınız olabilecek diğer şeyler ile birlikte bütün Güncellemelerinden paket yerine sadece Güncellemelerinden komut satırı araçları yüklemek için seçebilirsiniz. xcode-select --install çalışan ve ekrandaki istemi izleyerek monte edilebilir.

Hatalr not: eğer hata alırsanız "RVM bir fonksiyonu değildir" bu komut çalışırken, ziyaret: çözüm için How do I change my Ruby version using RVM?.

Bunu Paylaş:
  • Google+
  • E-Posta
Etiketler:

YORUMLAR

SPONSOR VİDEO

Rastgele Yazarlar

  • Christopher Bill

    Christopher

    30 NİSAN 2009
  • How To Cook That

    How To Cook

    16 NİSAN 2011
  • Karan Thakur

    Karan Thakur

    23 HAZİRAN 2010