SORU
8 EKİM 2010, Cuma


RMagick ımagemagick / - 't RMagick 2.13.1 yükleyebilirsiniz. Can't Büyüler-config bul

ImageMagick yüklemek için bir komut dosyası http://github.com/masterkain/ImageMagick-sl kullandım

Bir süre sonra, ImageMagick yüklü aldım.

Sonra sudo gem install rmagick araştırdım ve buldum

Building native extensions.  This could take a while...
ERROR:  Error installing rmagick:
ERROR: Failed to build gem native extension.

.rvm/rubies/ruby-1.9.2-p0/bin/ruby extconf.rb
checking for Ruby version >= 1.8.5... yes
checking for gcc... yes
checking for Magick-config... no
Can't install RMagick 2.13.1. Can't find Magick-config in...

Ruby 1.9.2 ve Raylar 3) Kar Leoparı çalışıyorum. Herhangi bir fikir?

CEVAP
14 Kasım 2010, Pazar


Aynı hatayı alıyordum ve ubuntu 11 libmagick9-dev kitaplığı yükledikten sonra çözüldü.

Güncelleme(Yorumların için teşekkürler. - Dec. 2012)

$ sudo apt-get install libmagickwand-dev ya da ubuntu 12 $ sudo apt-get install graphicsmagick-libmagick-dev-compat

$ sudo apt-get install libmagickwand-dev veya aşağıda ubuntu 11 veya $ sudo apt-get install libmagick9-dev.

Otomotiv - $ yum install ImageMagick-devel

Mac OS (Homebrew kullanarak), $ brew install imagemagick

Bunu Paylaş:
  • Google+
  • E-Posta
Etiketler:

YORUMLAR

SPONSOR VİDEO

Rastgele Yazarlar

  • Fraser Raft

    Fraser Raft

    9 Mart 2010
  • Lancome USA

    Lancome USA

    30 HAZİRAN 2009
  • snookie77

    snookie77

    2 Mart 2006