SORU
10 Aralık 2012, PAZARTESİ


Android Emülatörü: Yükleme hatası: İNSTALL_FAİLED_VERSİON_DOWNGRADE

Şu anda derleme ve küçük bir Android Uygulaması test etmek için çalışıyorum.

Eclipse kullanıyorum ve 4.2 (Seviye 17 Apı) yüklü SDK var. Ayarladım

<uses-sdk android:targetSdkVersion="17" android:minSdkVersion="8" />

ayrıca farklı değerler (17/17 yani) denedim ancak.

Herhangi bir GoogleAPİ fonksiyonları kullanmayın, ne de API Düzeyinde 8 mevcut olmayan işlevleri kullanırım. Ya da en azından bu konuda hata veya uyarı derleme alamadım.

Ben projeyi derlemek ve gerçek bir Android 2.2.1 çalıştıran bir bilgisayarda çalıştırdığınızda, Uygulama iyi çalışır. Bir emülatör uygulaması (Android Sanal Cihaz) çalıştırmayı denediğimde ancak 4.2, Android Apı Level 17 ile aşağıdaki hatayı alıyorum:

[2012-12-10 21:10:29 - SoftKeyboard] Installation error: INSTALL_FAILED_VERSION_DOWNGRADE
[2012-12-10 21:10:29 - SoftKeyboard] Please check logcat output for more details.
[2012-12-10 21:10:29 - SoftKeyboard] Launch canceled!

Logcat ancak boş. Gerçekten bu hata bile ne anlama geldiğini hiç bir fikrim yok

CEVAP
10 Aralık 2012, PAZARTESİ


Demek çalışıyorsun yüklemek için bir uygulama ile aynı packageName gibi bir uygulama bu zaten yüklü öykünücüsü, ama sen denemeye yüklemek için bir alt versionCode (tamsayı değeri için sürüm numarası).

Sürüm numarası ile şu anda çalıştığın kopya daha yüksek olduğu kod ayrı bir kopyası yüklü olabilir. Her iki durumda da:

  • yüklü bir kopyasını kaldırın

  • ya da telefonunuzun Ayarlar ^ aç . Yüklü uygulama ve artım senin için sürüm numarasını belirlemek için uygulama Yöneticisi 4 ** AndroidManifest yüksek olması.

  • veya http://stackoverflow.com/a/13772620/632951

Bunu Paylaş:
  • Google+
  • E-Posta
Etiketler:

YORUMLAR

SPONSOR VİDEO

Rastgele Yazarlar

  • Andrey Menshikov

    Andrey Mensh

    28 Ocak 2012
  • Ciaran Blumenfeld

    Ciaran Blume

    20 NİSAN 2009
  • cyriak

    cyriak

    29 Mart 2006