SORU
12 Mayıs 2012, CUMARTESİ


Hatayı düzeltmek için nasıl "Güncelleme Maven Projesi". Desteklenmeyen İClasspathEntry tür=4?

Alıyorum güncelleme projeyi çalıştırdığımda STS ithal maven projesi var:

"Updating Maven Project". Unsupported IClasspathEntry kind=4

Bunun için bir çözüm var mı?

CEVAP
14 Mayıs 2012, PAZARTESİ


Bu sorunu Eclipse Kepler (4.3) ve Luna (4.4) için mevcut olan m2e 1.5.0 düzeltildi

Lütfen https://bugs.eclipse.org/bugs/show_bug.cgi?id=374332#c14 bkz

Sorunun nedeni aslında STS (Spring IDE/güneş Tutulması), güneş Tutulması ve diğer Eclipse tabanlı IDE kullanın m2e(gereği) eklenti ama eclipse:güneş tutulması oldu ve muhtemelen kaçak proje. M2e bir karşılaştığında "" . var sınıf giriş, bu hata atar.

Güncelleme siteleri aşağıdaki url belirtilen:http://eclipse.org/m2e/m2e-downloads.html

Eğer herhangi bir nedenle m2e 1.5.0 kullanabilirsiniz eğer doğru değilse, o zaman :

  1. Proje için maven nature (sağ tıklama menüsü üzerinden) devre dışı bırakın

  2. mvn eclipse:clean (proje yaparkenaçıniçinde STS/tutulma). Zamanlama bağlı olarak, yeniden etkinleştirme maven doğasına önce proje ile ilgili bir iki yenileme yapmak gerekebilir. Sizin proje Maven doğa kaybettiğini görmek gerekir. (eclipse:clean amaç .project, .classpath .settings//dizinleri ve dosyaları siler. Ayrıca sadece bu dosyalar (tekrar kaldırsınproje açıkken)*. *7) çalıştırmak yerine

  3. Yeniden etkinleştirmek maven doğa.
    (Çoğu zaman, bu paket explorer bölmesinde söz konusu proje üzerinde sağ tıklayarak ve daha sonra seçerek yapılabilir ' -^'. Yapılandırmak 'Maven Projesine dönüştürmek')

Bunu Paylaş:
  • Google+
  • E-Posta
Etiketler:

YORUMLAR

SPONSOR VİDEO

Rastgele Yazarlar

  • Karan Thakur

    Karan Thakur

    23 HAZİRAN 2010
  • Phlearn Photoshop and Photography Tutorials

    Phlearn Phot

    11 EKİM 2011
  • Stanislav Petrov

    Stanislav Pe

    7 ŞUBAT 2009