SORU
26 EKİM 2013, CUMARTESİ


Komut Satırı Araçları ile Mavericks üzerinde xcodebuild kullanamıyor yüklü

Komut Satırı Araçları yüklü:

$ xcode-select --print-path
/Library/Developer/CommandLineTools

Bir şey xcodebuild, kullanmaya çalıştığında, ancak aşağıdaki hatayı alıyorum:

$ /usr/bin/xcodebuild
xcode-select: error: tool 'xcodebuild' requires Xcode, but active developer directory '/Library/Developer/CommandLineTools' is a command line tools instance

Dağ Aslanı üzerinde böyle büyük mükafat değil, sadece Komut Satırı Araçları bir bütün kurmadan kullanmak mümkün oldu. Mavericks üzerinde bunu yapmak mümkün mü? Nasıl çalışabilirim?

N. B. Bu birtemiz bir kurulumMavericks.

Güncelleme:sadece göstermek için, Komut Satırı Araçları yüklü var:

$ gcc --version
Configured with: --prefix=/Library/Developer/CommandLineTools/usr --with-gxx-include-dir=/usr/include/c  /4.2.1
Apple LLVM version 5.0 (clang-500.2.79) (based on LLVM 3.3svn)
Target: x86_64-apple-darwin13.0.0
Thread model: posix

CEVAP
19 Aralık 2013, PERŞEMBE


) xcodebuild XCode düzgün tek) ile çalıştı önce Komut Satırı Araçları yüklü yüklü olmasını gerektirecek şekilde değişmiş gibi görünüyor.

Yarı ilgili eski cevap

Birçok kişi bu Düğüm ile karşılaştım. Düğümün inşa aracı, gyp, xcodebuild düğüm paketleri derlemek için hazırlamak için kullanır. Mavericks, artık düzgün gyp ile çalışır xcodebuild davranışları değişti. Şu anda tamir ediliyor. See the node-gyp issue

Değişiklikleri etmesinin önünü dağıtıldıktan sonra node-gyp yeni paket yüklemek ve düzgün derlemek mümkün olacak. Ayrıca değişiklikleri etmesinin önünü içine dahil sonra etmesinin önünü sürümü güncellemeniz gerekir.

Bunu Paylaş:
  • Google+
  • E-Posta
Etiketler:

YORUMLAR

SPONSOR VİDEO

Rastgele Yazarlar

  • DavidParody

    DavidParody

    17 EKİM 2009
  • NCIX Tech Tips

    NCIX Tech Ti

    2 Ocak 2007
  • ThePhestor

    ThePhestor

    22 Mart 2011