SORU
29 Mayıs 2011, Pazar


Neden't Aslan RVM kullanarak Raylar yükleyebilirsiniz?

Sorunları OS X Lion üzerinde Raylar RVM kullanarak yüklemeye çalışıyorum karşılaştım.

Şu ana kadar şunları yaptım:

  1. Mac OS X Lion 10.7 Sürümü (11A459e İnşa) yüklü.
  2. Yüklü 4.1 Geliştirici Önizleme 5 Güncellemelerinden.
  3. RVM yüklü.
  4. Ruby 1.8.7 ile bir sürümü yüklü komutunu kullanarak RVM rvm install 1.8.7. Not: 1.8.7 ve 1.9.2 kullanmıyor olması gerekiyor.
  5. Ruby 1.8.7 version komutu rvm 1.8.7 kullanarak geçti.
  6. Yeni bir sınıfın bağımlı olduğu metodları komutu rvm gemset create rails3 kullanılarak oluşturulan.
  7. Yeni bir sınıfın bağımlı olduğu metodları komutu rvm use 1.8.7@rails3 kullanarak geçti.
  8. Yükleme komutu gem install rails koştum Raylar ama aşağıdaki hatayı aldım:

    /Kullanıcılar/m/.rvm/yakut/yakut-1.8.7-p334/lib/ruby/1.8/zaman aşımı.:60 rb: [HATA] Segment hatası

Aynı hatayı bir mücevher komut çalıştırmayı denerken oluyor gerçekten Raylar ile ilgili bir sorun olduğunu sanmıyorum.

Bağlantılar aşağıda bakılırsa, tek kişi bu sorunu yaşıyor sanki bilmiyorum:

http://twitter.com/#!/pingles/status/66261101351927809 10**

CEVAP
30 Mayıs 2011, PAZARTESİ


Tamir!

Cevap aslında yukarıda yayınlanan halkalarından biri oldu. Çalıştırmak için gerekli ruby (1.8.7 rvm install) bir sürümünü yüklemeden önce "export CC=/usr/bin/gcc-4.2". Yerde, her şey sorunsuz gitti.

Eğer CC kalıcı olarak dışa olmasını istemiyorsun. öyleyse CC=/usr/bin/gcc-4.2 rvm install 1.8.7 yapabilirsiniz

Zaten ruby 1.8.7 yüklü. Yap CC=/usr/bin/gcc-4.2 rvm reinstall 1.8.7

Bunu Paylaş:
  • Google+
  • E-Posta
Etiketler:

YORUMLAR

SPONSOR VİDEO

Rastgele Yazarlar

  • Bach Vlogs

    Bach Vlogs

    18 HAZİRAN 2011
  • Klemens Torggler

    Klemens Torg

    11 Mart 2008
  • Murray Winiata

    Murray Winia

    2 ŞUBAT 2009